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Introduction

The Format as HTML tool is used to create a task step that produces single or multiple HTML documents. You can

choose to create the HTML template from scratch or import a pre-existing template. Recordsets and other task step

properties can also be used to populate the HTML template to produce dynamic content documents. These

documents can then be consumed and then delivered by Output or Execute task steps.

Features
4 Create or use existing HTML documents
4 Merge data from other task steps
4 Full support for embedded graphics and backgrounds
4 Create single or multiple documents depending on the information
4 Document preview
4 HTML Table Designer
O  Data formatting

O 0 0O O

Hyperlink support
Auto-hyperlink detection for dynamic data
Formatting of fonts, borders, colours, backgrounds

Sub- and grand total
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Technical Summary

NOTE: The Format as HTML tool supports basic HTML features. For new development, including HTML 4.0 and

HTML 5 support, we recommend using the Format as HTML Pro (for more information, refer to the Format as
HTML Pro White Paper).

Working with other Tools

The Format as HTML tool can directly interact with the following tools:

Consuming From Other Tools

The Format as HTML tool can consume objects outputted by the following tools:

Icon

Tool Name

Tool Category

Database Query (ODBC)

Database Query (OLEDB)

Call Stored Procedure (OLEDB)

Import Flat File

Convert XML to Recordset

Filter Data

Input and Data Connectors

Input and Data Connectors

Input, Data Connectors, Output, and Execute

Input

Format

General

NOTE: The Format as HTML can only consume from the Call Stored Procedure (OLEDB) tool whenitis

outputting recordsets.
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Objects Consumed

The following objects, outputted by the above tools, can be directly consumed by the Format as HTML tool:

>

Recordset — Tabular data from any BPA Platform tool capable of exposing such data (see above)

Exposing to Other Tools

Objects exposed by the Format as HTML tool can be directly consumed by the following tools:

Icon Tool Name

Tool Category

Save File

Send Email (SMTP)

Transfer File (FTP)

Call COM Object

Run External Program

Run VBScript

Aol da

Objects Exposed

The following objects, exposed by the Format as HTML tool, can be directly consumed by the above tools:

>

Output

Output

Output

Execute

Execute

Execute

Documents (HTML) — Standalone HTML pages

RecordSource — If an Input Recordset has been selected (see General tab), this contains the columns

included in the recordset

Step Properties — Standard step properties are available allowing you to use statistical data of the tool
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Global Configuration

The Format as HTML tool does not require any global configuration before being used in a task. However, it is

recommended you create basic HTML templates for use in the task step — see Formatting tab.

HTML Editor
Before you can edit HTML pages imported into the Format as HTML task step, you must assign a default HTML

Editor. You do this in the operating system's Control Panel. Open Internet Options > Programs tab, and from the

HTML editing section, select Notepad.
Step Configuration

To add a new Format as HTML step to an existing task, you either:

4 Click and drag the Format as HTML icon from the Task Browser to the task Design area.

4 From the task's Design tab, right-click on empty space and select Add > Format > Format as HTML.

For a detailed description of how to create new tasks, refer to the product help.
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About the General Tab

T Format as HTML

General Formattng Options
Mame : | Format as HTML
Description :
Use a Recordset
Input Recordset ;| Results from Database Query (CDBC) ~
Canc

The General tab is used to enter the following details for the step:

4 Name — Enter a meaningful name for the step

TIP: If this task instance makes use of two or more Format as HTML steps, ensure the Name used is unique for

each individual step.

4 Description — If required, enter a description of this step

4 Use a Recordset — Enable this parameter if recordset data from a previous task step is required to form the
document
O Input Recordset — Contains all available recordsets from steps previously created in the task
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About the Formatting Tab

Create your HTML documents in the Formatting tab.

™ Format as HTML

General Formatting Options

Document Generation Options
(®) One document

() New document when column changes : EventCategory v
() Mew document for each row

Table Formatting

Insert Bold | |Underline | | Italics

Preview

Edit

Impaort

I oK Il Cancel |

If Not Consuming a Recordset

If the Format as HTML step is not set to consume a recordset from a previous task step (see General tab), you can
only output a single HTML document at run-time.

You can still use variables, step properties, and other data from the Task Browser to generate dynamic data.

If Consuming a Recordset

If the Format as HTML step is set to consume a recordset from a previous task step (see General tab), you can
output a single or multiple HTML documents.

One Document Generation

A single HTML document is created containing all records from the recordset.
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New Document when Column Changes Generation

A new HTML document is created when the nominated recordset column's value changes. For example, column
name companyname groups all the records where companyname = "Codeless Platforms" into one document and
each subsequent company into a new document.

New Document for Each Row Generation

A new HTML document is created for each row in the consumed recordset.

Using the HTML Designer

Typically, you would Import an existing HTML template into the design area and add BPA Platform data from the

Task Browser.

NOTE: Any text typed directly into the design area is treated as plain text; this includes any HTML constructs you
may have added. Instead, click Edit to open the HTML template in Notepad — if you see a warning advising the
HTML editor cannot be found or opened, go to Control Panel > Internet Options > Programs tab and select
Notepad as the HTML Editor. However, recordset columns, variables, and step properties added to the

template from the Task Browser remain as dynamic data placeholders rather than plain text.

If required, you can display recordset data as a table (not available if generating a New document for each row) —
click Design to create the HTML table (see About the HTML Table Designer).

About the HTML Table Designer

The HTML Table Designer is used to create an HTML table incorporating data from a consumed recordset from a

previously created task step — see General tab.
You add recordset columns in the Columns tab and style them in the Formatting tab.

Use Preview to view the table during design time.
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About the Columns Tab

Here you specify the columns from the input recordset (see General tab) that make up the table.

W HTML Table Designer

Columns  Formatting

Columns

Object

Visible:

Column Heading :
Percentage Width :
Data Format :
Hyperlink:

Sub Total :

Section Break :
Grand Total :

Event ID

{=This5tep.Reco...

v
Event ID
100
Murmeric
(Auta)

A0

Category

{=This5tep.Reco...

v
Category
100
MNumeric
(Auto)
r

r

r

Type Description Source
{=This5tep.Reco... {=ThisStep.Reco... {=ThisStep.Re
v v v
Type Description Source
100 100 100
MNumeric Text Text
(Auto) (Auto) (Buta)

r
r r r
r

Preview Cancel

Drag-and-drop recordset columns from the Task Browser to the design area. To change the column order, click and

drag the relevant column to its new location.

Additional formatting is available for each column:

Format

Description

Object

Visible

Column
Heading

Percentage

Width

The recordset source for this column, as VB script.

The column heading as displayed in the final output.

By default, all columns added to the table are visible in the output. Use the Visible toggle to add a
recordset column that is used to calculate a sub-total but is not shown in the final output.

The width of the column as a percentage of the entire table width. By default, each columnis set to
100% so must be changed at design time to ensure best-fit.

{ TIP: Set Percentage Width to 0 to force the browser to use its own sizing algorithm.
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Format Description

Data The data format of the recordset column. Use the ellipsis button to change the format:
Format >
Text
4 Numeric

> Date/Time

4 Currency

All data formats have additional formatting available where you can choose to use the same
formatting available through your operating system, or use custom formatting for this particular

column only. All standard formats are available.

| [=ThisStep.RecordSource(EventID)}

[ ] Open in New Window
idth ; 400 2| Height:
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Format Description

Sub Total If the recordset column is either of Numeric or Currency data format, you can choose to add the

values and display the value in a new row.
Use Section Break to add a new sub-total row and value for a new set of table rows,

Section Although available for every column, a section break should only be enabled for "sort" columns in
Break either the Database Query (ODBC) or Database Query (OLEDB) task step. Every time the value of
the column changes, a section break is added. This is particularly useful when using sub-totals.

Grand If the recordset column is either of Numeric or Currency data format, you can choose to add the

Total values and display the value at the bottom of the table.

About the Formatting Tab

Use the Formatting tab to style the HTML table.

W HTML Table Designer

Columns Formatting

(®) Table (O mitle () Sub Total (") Section Title () Grand Total

Layout Borders Background Font

Horizontal alignment: Default w [] spedify width:
Vertical Alignment: Default w 0 In pixels
Float: Default - In percent

Cell padding: 1 = [ specify height:
Cell spacing: 1 = i In pixels

D Mo wrap In percent

Select Profile Save Profile

Preview Cancel

If after you've finished formatting this table, you want to re-use the formats for another Format as HTML table in

another task or step, use Save Profile.
To use an existing table format here, use Select Profile to load the relevant format.

You can change the layout, border, background, and font of the following:

4 Table — Properties specified here affect the whole table
4 Title — Properties specified here affect the top table heading row
> Sub Total — Properties specified here affect the sub-total row if enabled (see Sub Total)

10 of 12



4 Section Title — Properties specified here affect section breaks if enabled (see Section Break)

4 Grand Total — Properties specified here affect the grand total row if enabled (see Grand Total)

About the Options Tab

The Options tab allows you to define how errors in this step are handled at task runtime.

™ Format as HTML

Germeral Formatting Options

Formatting Options
Treat Source Data as :

(®) HTML

i) Text

If an error ooours :
(®) Abort Task
l:::l Continue

Cancel

If the consuming recordset contains HTML data, you can choose how to Treat Source Data:

4 HTML — If data in a recordset contains HTML tags, enabling this option processes such data as HTML and

outputs accordingly. For example, <b>Name</b>, <em>Description</em> would be outputted as Name,

Description.

4 Text — All data in a recordset column, including any HTML tags, is processed as plain text and outputted as

such. For example, <b>Name</b>, <em>Description</em> would be outputted exactly as is.
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NOTE: The Formatting Options panel is just for HTML data found in the source recordset, not for processing

any HTML tags typed into the Formatting tab's design area.

If an error occurs, you can decide whether the step should Continue processing, or terminate the step immediately
(Abort Task).
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Want to learn more?

Discover how Codeless Platforms can help your business by improving
performance, boosting efficiency and cutting costs.

D +44 (0) 330 99 88 700
KA enquiries@codelessplatforms.com

@ www.codelessplatforms.com
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