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Introduction

The Transfer File (FTP) Tool is used to create a Task Step that uploads or downloads one or more files to and from

one or more FTP Servers. This is a powerful tool which can be used, for example, in the automated publishing of key

information to Intranet / Internet sites.

When uploading, the files in question may be created by BPA Platform Steps or may already exist within an

accessible file system. For example, documents produced by the Format type Steps can be produced dynamically and

uploaded to an FTP site in a single Task.

Multiple FTP servers and their authentication details can be defined globally and their use is then transparent in the

rest of the product.

A list of files or folders to be transferred by the Step is defined in the Main tab of the Transfer File (FTP) dialog box.

Within each file transfer definition, it is possible to specify options controlling upload or download, static or dynamic

FTP Server to use and static or dynamic files.

Features

 Transfer single or multiple files to and from FTP sites

 Multiple up/down transfer definitions per Step

 Static or dynamic files and documents

 Supports Data in Binary columns from data sources

 Static or dynamic FTP Sites, Ports and Authentication

 Passive or Active mode

 Supports Binary Transfers

 File exists options

 FTP Site Authentication

 Memory features to memorise Task data created at run time
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Technical Summary

Working with other Tools

The other tools that the Transfer File (FTP) tool interacts directly with, whether by exposing information to it or

consuming information from it, are listed below.

Consuming from Other Tools

Icon Tool Name Tool Category

Database Query (ODBC) Input and Data Connectors

Database Query (OLEDB) Input and Data Connectors

Import Flat File Input

Convert XML to Recordset Format

Create Workflow Job Format

Format as Flat File Format

Format as HTML Format

Format as HTML Pro Format

Format as Text Format

Run Crystal Report Format

Run Microsoft Reporting Services Format
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Icon Tool Name Tool Category

Run Microsoft Word (Merge) Format

Filter Data General

Objects Consumed

Objects that the Transfer File (FTP) Step consumes that are exposed by other Steps are listed below.

 Recordset — Information structured into columns and rows

 Documents (Any) — Documents of any type

 Variables (Text) — Textual data is extracted from selected Variables

Exposing to Other Tools

The Transfer File (FTP) tool does not expose recordsets, variables, or XML that can be directly consumed by other

tools.

Objects Exposed

Objects that the Transfer File (FTP) Step exposes that can be utilised by other Steps are listed below.

 RecordSource — If an Input Recordset has been selected from a Step previously created in the Task, then it

displays the columns included in the recordset.

 DocumentSource — If a Document Source has been selected from a Step previously created in the Task,

then it displays the columns included in the recordset used by the Step.

 Memory Definitions — Displays a list of Memory Definitions created for the Step and the columns to be

memorised for each one. Double-clicking on a Memory Definition then opens the applicable memory

configuration dialog box to enable the details to be edited.

 Step Properties — A number of properties for the Step are exposed in the Environment tab of the Task

Browser dialog box
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Dependencies

The products, technologies, protocols or systems that are required for the Transfer File (FTP) Step to work are listed

below.

 FTP Site — Conforming to RFC 959

NOTE: The Transfer File (FTP) tool supports standard FTP only. For FTP, SFTP, FTPS (Explicit and Implicit), and

HTTP / HTTPS protocols, use the File Management tool.

Connecting to an FTP Server

Before adding a Transfer File (FTP) step to a task, you must first add a connection to the required FTP server.

You open the global configuration dialog by either:

 Going to Manage > Tools > Output > Transfer File (FTP)

 From the Task Manager, expanding BPA Platform > System > Tools > and double-clicking Transfer File (FTP) in

the Items List

Use Add to add a new FTP connection (New Connection dialog box).

Use Properties to edit the highlighted connection details (Update Connection dialog box).
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Use Test to test the highlighted connection. A dialog box pops up to display the test results.

TIP: You may need to register the FTP server's certificate for use with the BPA Platform server; if an untrusted

certificate is found, runtime activity may fail to authenticate. For a detailed description of how to register the

certificate, refer to our knowledge base article How to register a third party server certificate for use on a BPA

Platform server.

Adding a New FTP Connection

The dialog box is used to create a new connection to an FTP Server and contains the following:

 Connection Name — A name for the new connection may be manually entered.

 Server — The name of the server to be used may be manually entered.

 Port — The port number to use may be entered. The default used is port 21.

 Anonymous login — Check the box if anonymous login is required.
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 User name — The user name required to access the connection may be manually entered.

 Password — The password required for the user name may be manually entered.

 Passive Mode — Passive mode makes your ISP responsible for server and firewall access, with the BPA

Platform server acting as an FTP client. Select if passive mode is required.

 Test — Select to test the connection.

Updating FTP Connections

The dialog box allows details for a highlighted connection to be displayed and edited and contains the following:

 Connection Name — The connection name may be manually edited

 Server — The server name may be manually edited

 Port — The port number may be manually edited

 Anonymous login — The box may be selected as required
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 User name — The user name may be manually edited

 Password — The password may be manually edited

 Passive Mode — The box may be selected as required

 Test — Select to test the connection

Step Configuration

To add a new Transfer File (FTP) step to an existing task, you either:

 Click and drag the Transfer File (FTP) icon from the Task Browser to the task Design area.

 From the task's Design tab, right-click on empty space and select Add > Output > Transfer File (FTP).

For a detailed description of how to create new tasks, refer to the product help.
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About the General Tab

The General tab is used to enter the following details for a Transfer File (FTP) Step:

 Name — A unique name for the Step may be manually entered. The name is used to identify the Step within

the Task and particularly within the Task Plan. It is advisable to name the Steps as accurately as possible so

that the Task Plan itself gives the user a good impression of the overall Task process at a glance.

 Description — A description for the Step may be manually entered. The description is used to explain what

the Step does and how it is configured to achieve this. When maintaining the Task, this helps users

understand how the Task works.

 Use a recordset — When selected the Input recordset drop down list is active.

 Recordset — All available recordsets from Input Steps previously created in the Task are displayed in

a drop down list for selection.

 Read documents from a source — When selected the Document Source drop down list is active.

 Document Source — All available documents from Format steps previously created in the Task are

displayed in a drop down list for selection.
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About the Main Tab

The Main tab allows the selection of files to be uploaded or downloaded, and the target FTP Servers.

The dialog box contains the items listed below.

 Files — A list of file details is displayed under the following headings:

 Source — Shows the static file name, or the data column from which it is being derived.

 Destination — Shows the destination path for the file, or the data column from which it is being

derived.

 Type — Displays Upload or Download.

 Server — Displays the name of the FTP connection or the FTP server being used, depending on

whether a static or dynamic server is being used.

 Add — Opens the File Item Add dialog box through which a new file may be added to the list.

 Edit — Opens the File Item Add dialog box and displays details for the selected file which may then be edited.

 Remove — Removes the selected document from the list.
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 Up Arrow — Moves the selected file up one place in the list each time the button is selected. When the Task is

run, files are transferred in list order.

 Down Arrow — Moves the selected file down one place in the list each time the button is selected.

 Memory — Displays the Memory Definitions dialog box through which a Repository may be created to

memorise some or all of the recordset used by the Step.

About the File Item Add Dialog

The File Item Add dialog box is displayed when the Add button is selected in the Main tab.

About the Server Tab

The Server tab is the default tab displayed when the File Item Add dialog box is displayed and is used to select

either a static server connection or to enter data dynamically for each server setting where the data is available in a

column from the data source being used.
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The tab contains the options listed below.

 Static — This option is used where a fixed server connection is to be used and provides the following:

 Connection — Displays a list of available connections for selection.

 Dynamic — This options provides the following for configuring the server connection settings:

 Server — A server path and name may be manually entered or a database column or variable

containing the path and name dragged and dropped into the field from the Task Browser.

 Port — The port number to be used may be manually entered or a database column or variable

containing the port number dragged and dropped into the field from the Task Browser.

 User — The user name to be used may be manually entered or a database column or variable

containing the user name dragged and dropped into the field from the Task Browser.

 Password — The password to be used for the selected user name may be manually entered or a

database column or variable containing the password dragged and dropped into the field from the

Task Browser.

 Passive — This field is used to select a "passive" connectivity to the recipient FTP Server. From the

drop down list, options of True or False may be selected. Alternatively you may drag and drop a

property from the Task Browser dialog box into the field but this property must resolve to either True

or False. The Client can then initiate both parts of the FTP connection (Data & Command) to reduce the

risk of firewalls filtering the Data Port information.

 Options — Checking this option drops the connection to the server after the file transfer.
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About the File Transfer Tab

The File Transfer tab of the File Item Add dialog box is used to configure all file transfer settings through the

following:

 Upload — Select when files are to be uploaded to an FTP Server.

 Download — Select when files are to be downloaded from an FTP Server.

 Source — Contains the following options for selecting a file source:

 Full Path and Filename(s) — The path and name may be manually entered or located and selected

through a Browse button. Alternatively, a database column or variable containing the path and name

may be dragged and dropped into the field from the Task Browser.

 File from Data — This option is only available when the Use a recordset option is selected in the

General Tab. A database column or variable containing the file may be dragged and dropped into the

field from the Task Browser.

 File from Document — This option is only available when the Read documents from a source

option is selected in the General tab. The source file is automatically selected.
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 File(s) in Folder — A folder path and name containing the file(s) may be manually entered or selected

through a Browse button. Alternatively, a database column or variable containing the folder path may

be dragged and dropped into the field from the Task Browser.

 Include subfolders — Includes any sub-folders for the selected folder.

 Destination — Contains the following options for selecting a destination for the files:

 Path — The destination path may be manually entered or located and selected through a Browse

button. Alternatively, a database column or variable containing the path may be dragged and dropped

into the field from the Task Browser.

 Create destination folder if not found — Creates a destination folder for the transferred files if it

does not already exist.

 Destination Filename(s) — The destination file name may be manually entered or located and

selected through a Browse button. Alternatively, a database column or variable containing the

filename may be dragged and dropped into the field from the Task Browser.
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About the Options Tab

The Options tab allows you to define how errors in this step are handled at task runtime.

If a file with the same name exists in the destination path, you can chose whether to overwrite.

NOTE: If Never Overwrite is selected, the new file data is not saved.

If an error occurs, you can decide whether the step should Continue processing, or terminate the step immediately

(Abort Step).

If the step is aborted, you can choose to Continue processing onto the next step in the task, or terminate the

whole task immediately (Abort Task).

Select Binary Transfer to allow binary file transfers.
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